解决WordPress自带jQuery和插件自带的jQuery冲突问题(禁止程序自带)

今天在调整网站的时候发现一个怪事儿,在启动某个插件的时候发现插件无法使用,检查是没有jQuery,这里实际上可以通过代码看到他插件有自带jQuery,而且WordPress程序也是有自带的。那是不是2个jQuery导致冲突,那禁止掉一个看看。

//禁止前端JQ
if ( !is_admin() ) { 
function my_init_method() {
wp_deregister_script( 'jquery' );
}
add_action('init', 'my_init_method');
}
wp_deregister_script( 'l10n' );

这里我们可以在前端看到只有插件自带的JQ。不过有个问题,如果有的插件必须要借助WP程序的JQ,我们还不能单独设置禁止,还需要启动或者给这个你的插件单独禁止就保留程序自带的jQuery。

© 版权声明
THE END
喜欢就支持一下吧
点赞8 分享